re = /\d+(?!\D)/m
str = '1text
text5
who is 1st here
1990 2000 3000
numbers 4
3.141'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end