$re = '/\d+(?!\D)/m';
$str = '1text
text5
who is 1st here
1990 2000 3000
numbers 4
3.141';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);