re = /(?:(?<!\[)|(?!.{4}\]))(.)(?!\1)(.)\2\1/m
str = 'Any 4 char sequence which has a pair of two different characters followed by the reverse of that pair e.g xaax or raar. The string is not considered valid if the pattern above exist in square brackets.
[xaax
xaax]
[xaax]
[raar
raar]
[raar]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end