package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)}$[\s\S]*?}$`)
var str = `está no fim da linha, deve pegar -> }
qualquer texto, \" blablá etc
linha } <- não está no final da linha, deve pular
tem que pegar esse, pois está no fim da linha }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \" blablá etc
asdasdasasdsa}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}