const regex = /}$[\s\S]*?}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('}$[\\s\\S]*?}$', 'gm')
const str = `está no fim da linha, deve pegar -> }
qualquer texto, \\" blablá etc
linha } <- não está no final da linha, deve pular
tem que pegar esse, pois está no fim da linha }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \\" blablá etc
asdasdasasdsa}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}