re = /}$[\s\S]*?}$/m
str = 'está no fim da linha, deve pegar -> }
qualquer texto, \\" blablá etc
linha } <- não está no final da linha, deve pular
tem que pegar esse, pois está no fim da linha }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \\" blablá etc
asdasdasasdsa}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end