const regex = new RegExp('((?:[01]\\d|2[0-3]):(?:[0-5]\\d):(?:[0-5]\\d)) \\| (Player) \\"(.+)\\" (.+) \\(id=(.+)= (.+)=<(.+)>(.+)\\"(.+)\\" \\(id=(.+)=(.+)\\=<(.+)\\>(.+)with (.+) from (.+) meters', 'gim')
const str = `18:43:44 | Player "Holomo33" (DEAD) (id=2vL1MZXKHD4qwgO6NSjoThiISfINy5SmNmuhAkbwYHM= pos=<4715.3, 10763.7, 346.8>) killed by Player "X-CYPHER-3" (id=aVfM8ohBvcljkZtt5CB77JOY7SNoBAh-sYK0ejvNPJc= pos=<4789.6, 10828.5, 335.4>) with LAR from 99.2274 meters
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}