package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\d+\.){2})?\d+$`)
var str = `1.22.33
3.44
12
1
7.77.55
8.88.88.99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}