import re
regex = re.compile(r"^(?:(?:\d+\.){2})?\d+$", flags=re.MULTILINE)
test_str = ("1.22.33\n"
"3.44\n"
"12\n"
"1\n"
"7.77.55\n"
"8.88.88.99")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")