$re = '/^(?:(?:\d+\.){2})?\d+$/m';
$str = '1.22.33
3.44
12
1
7.77.55
8.88.88.99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);