package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*<([.\w]+@\w+\.\w+)>`)
var str = `Joe Schmoe <joe.schmoe@gmail.com>`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}