re = /.*<([.\w]+@\w+\.\w+)>/m
str = 'Joe Schmoe <joe.schmoe@gmail.com>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result