const regex = new RegExp('.*<([.\\w]+@\\w+\\.\\w+)>', 'gm')
const str = `Joe Schmoe <joe.schmoe@gmail.com>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);