package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<index1>[^\:]+)\:(?<index2>[^\:]+)\:(?<index3>[^\:]+)\:\s(?<index4>[\S]+)\s(?<index5>[^\:]+)\:(?<index6>[^\:]+)\:(?<index7>[^\:]+)\:(?<index8>[^\:]+)\:\s*(?<index9>[^\s]+)`)
var str = `2016-11-04 06:32:50,120 [http-bio-8443-exec-10862] INFO : Start Outputing Report: Project ID:c_exactworld_17121, Format:HTML, Locale: en_US`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}