const regex = /^(?<index1>[^\:]+)\:(?<index2>[^\:]+)\:(?<index3>[^\:]+)\:\s(?<index4>[\S]+)\s(?<index5>[^\:]+)\:(?<index6>[^\:]+)\:(?<index7>[^\:]+)\:(?<index8>[^\:]+)\:\s*(?<index9>[^\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<index1>[^\\:]+)\\:(?<index2>[^\\:]+)\\:(?<index3>[^\\:]+)\\:\\s(?<index4>[\\S]+)\\s(?<index5>[^\\:]+)\\:(?<index6>[^\\:]+)\\:(?<index7>[^\\:]+)\\:(?<index8>[^\\:]+)\\:\\s*(?<index9>[^\\s]+)', 'g')
const str = `2016-11-04 06:32:50,120 [http-bio-8443-exec-10862] INFO : Start Outputing Report: Project ID:c_exactworld_17121, Format:HTML, Locale: en_US`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}