import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<index1>[^\\:]+)\\:(?<index2>[^\\:]+)\\:(?<index3>[^\\:]+)\\:\\s(?<index4>[\\S]+)\\s(?<index5>[^\\:]+)\\:(?<index6>[^\\:]+)\\:(?<index7>[^\\:]+)\\:(?<index8>[^\\:]+)\\:\\s*(?<index9>[^\\s]+)";
final String string = "2016-11-04 06:32:50,120 [http-bio-8443-exec-10862] INFO : Start Outputing Report: Project ID:c_exactworld_17121, Format:HTML, Locale: en_US";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}