package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@\S+`)
var str = `some text and @nickname and some text and @nickname more text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}