re = /@\S+/m
str = 'some text and @nickname and some text and @nickname more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end