$re = '/@\S+/m';
$str = 'some text and @nickname and some text and @nickname more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);