#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?:\A|\*{6})(?:(?!\*{6}).)*?BBB.*?(?=\R\*{6})"
Local $sString = "Some text here AAA" & @CRLF & _
"Some text here One" & @CRLF & _
"Some More text here" & @CRLF & _
"******" & @CRLF & _
"Some text here BBB" & @CRLF & _
"Some text here Two" & @CRLF & _
"Some More text here" & @CRLF & _
"******" & @CRLF & _
"Some text here CCC" & @CRLF & _
"Some text here Three" & @CRLF & _
"Some More text here" & @CRLF & _
"******" & @CRLF & _
"Some text here BBB" & @CRLF & _
"Some text here Four" & @CRLF & _
"Some More text here" & @CRLF & _
"******" & @CRLF & _
"Some text here BBB" & @CRLF & _
"Some text here Five" & @CRLF & _
"Some More text here" & @CRLF & _
"******"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")