re = /(?:\A|\*{6})(?:(?!\*{6}).)*?BBB.*?(?=\R\*{6})/m
str = 'Some text here AAA
Some text here One
Some More text here
******
Some text here BBB
Some text here Two
Some More text here
******
Some text here CCC
Some text here Three
Some More text here
******
Some text here BBB
Some text here Four
Some More text here
******
Some text here BBB
Some text here Five
Some More text here
******'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end