import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\A|\\*{6})(?:(?!\\*{6}).)*?BBB.*?(?=\\R\\*{6})";
final String string = "Some text here AAA\n"
+ "Some text here One\n"
+ "Some More text here\n"
+ "******\n"
+ "Some text here BBB\n"
+ "Some text here Two\n"
+ "Some More text here\n"
+ "******\n"
+ "Some text here CCC\n"
+ "Some text here Three\n"
+ "Some More text here\n"
+ "******\n"
+ "Some text here BBB\n"
+ "Some text here Four\n"
+ "Some More text here\n"
+ "******\n"
+ "Some text here BBB\n"
+ "Some text here Five\n"
+ "Some More text here\n"
+ "******";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}