$re = '/apidocs\/static\/[^\/]+[.](?:png|jpg|jpeg|gif|pdf)/m';
$str = './apidocs/static/mypicture.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);