re = /apidocs\/static\/[^\/]+[.](?:png|jpg|jpeg|gif|pdf)/m
str = './apidocs/static/mypicture.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end