#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\d+-\/*]+\s?)+"
Local $sString = "простая арифметика." & @CRLF & _
"простое выражение 22+8" & @CRLF & _
"выражения с случайными пробелами 11* 8 или 11 *8 или 11 * 8" & @CRLF & _
"выражение посложнее -99*8+3" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")