re = /([\d+-\/*]+\s?)+/m
str = 'простая арифметика.
простое выражение 22+8
выражения с случайными пробелами 11* 8 или 11 *8 или 11 * 8
выражение посложнее -99*8+3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end