using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d+-\/*]+\s?)+";
string input = @"простая арифметика.
простое выражение 22+8
выражения с случайными пробелами 11* 8 или 11 *8 или 11 * 8
выражение посложнее -99*8+3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}