using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2}\/\d{2}\/\d{4}(?=(?:(?!\d{2}\/\d{2}\/\d{4})[^])*?error)";
string input = @"harum voluptatibus laboriosam blanditiis similique commodi labore 09/09/4567 repellat error quasi animi nostrum magnam, ab asperiores unde porro! ipsum dolor sit amet, consectetur adipisicing elit. Velit, delectus esse aperiam quod aliquid sunt iure ducimus. Nesciunt eveniet, possimus 09/09/4568 adipisci accusamus reiciendis , quos pariatur, sapiente rem quaerat cumque.
one 01/01/1111 two error 02/02/2222 three four 03/03/3333 five error";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}