import Foundation
let pattern = #"\d{2}\/\d{2}\/\d{4}(?=(?:(?!\d{2}\/\d{2}\/\d{4})[^])*?error)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
harum voluptatibus laboriosam blanditiis similique commodi labore 09/09/4567 repellat error quasi animi nostrum magnam, ab asperiores unde porro! ipsum dolor sit amet, consectetur adipisicing elit. Velit, delectus esse aperiam quod aliquid sunt iure ducimus. Nesciunt eveniet, possimus 09/09/4568 adipisci accusamus reiciendis , quos pariatur, sapiente rem quaerat cumque.
one 01/01/1111 two error 02/02/2222 three four 03/03/3333 five error
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)