use strict;
my $str = 'harum voluptatibus laboriosam blanditiis similique commodi labore 09/09/4567 repellat error quasi animi nostrum magnam, ab asperiores unde porro! ipsum dolor sit amet, consectetur adipisicing elit. Velit, delectus esse aperiam quod aliquid sunt iure ducimus. Nesciunt eveniet, possimus 09/09/4568 adipisci accusamus reiciendis , quos pariatur, sapiente rem quaerat cumque.
one 01/01/1111 two error 02/02/2222 three four 03/03/3333 five error';
my $regex = qr/\d{2}\/\d{2}\/\d{4}(?=(?:(?!\d{2}\/\d{2}\/\d{4})[^])*?error)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}