package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`--\[\[[\S\s]*?\]\]`)
var str = `local text = [[ Lua
multi
line
string]]
--[[
multiline comment
--]]
--[[ alternative
multi-
line
comment
]]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}