$re = '/--\[\[[\S\s]*?\]\]/';
$str = 'local text = [[ Lua
multi
line
string]]
--[[
multiline comment
--]]
--[[ alternative
multi-
line
comment
]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);