import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "--\\[\\[[\\S\\s]*?\\]\\]";
final String string = "local text = [[ Lua\n\n"
+ "multi\n"
+ "line\n"
+ "string]]\n\n"
+ "--[[\n"
+ " multiline comment\n"
+ "--]]\n\n"
+ "--[[ alternative\n"
+ "multi-\n\n"
+ " line\n"
+ "comment\n"
+ "]]\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}