use strict;
my $str = 'sd12a1a';
my $regex = qr/\d(\d)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";