#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+\.?(?:\d{1,2})?) (\bmillions?\b|\bbillions?\b|\btrillions?\b|\bmeters?\b|\bmiles?\b|\%)"
Local $sString = "3 billion" & @CRLF & _
"3 million" & @CRLF & _
"3 %" & @CRLF & _
"2 meters"
Local $sSubst = "<span class='highlighted'>" $1_$2 "</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)