re = /(\d+\.?(?:\d{1,2})?) (\bmillions?\b|\bbillions?\b|\btrillions?\b|\bmeters?\b|\bmiles?\b|\%)/m
str = '3 billion
3 million
3 %
2 meters'
subst = '<span class=\'highlighted\'>" $1_$2 "</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result