const regex = /(\d+\.?(?:\d{1,2})?) (\bmillions?\b|\bbillions?\b|\btrillions?\b|\bmeters?\b|\bmiles?\b|\%)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.?(?:\\d{1,2})?) (\\bmillions?\\b|\\bbillions?\\b|\\btrillions?\\b|\\bmeters?\\b|\\bmiles?\\b|\\%)', 'gm')
const str = `3 billion
3 million
3 %
2 meters`;
const subst = `<span class='highlighted'>" $1_$2 "</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);