#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(?i)(?<AllTable>Lp[\s\a]*Opis[\s\a]*towaru\s*\/\s*uslugi[\s\a]*Ilość[\s\a]*jm\.[\s\a]*Cena[\s\a]*Wartosc\s*VAT[\s\a-]*[\s\S]*?)Razem[\s]*:[\s]*(?<WartoscNetto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<KwotaVAT>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<WartoscBrutto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))[\s\a]*Do\s*Zapłaty\s*:\s*(?<DoZaplaty>\k<WartoscBrutto>)\s*[a-z]{3}"
Local $sString = "AKTURA FV000821 :JAAC*fibf:" & @CRLF & _
"DATA WYSTAWIENIA : 2020.06.08 ZLECENIE: 01" & @CRLF & _
"MIEJSCE WYSTAWIENIA : TORUŃ" & @CRLF & _
"DATA DOSTAWY TOWARU : 2020.06.08 UWAGI : zam. T561552 Z1" & @CRLF & _
"SPRZEDAWCA: "MEGA-TOOLS" S.C." & @CRLF & _
" Marek Śpiewak,Mirosław Śpiewak ul.Osikowa 34 87-100 Toruń NIP 9562093313" & @CRLF & _
" ING Bank Śląski S.A. O/Toruń" & @CRLF & _
" 49 1050 1979 1000 0022 7285 0849" & @CRLF & _
" NABYWCA: Pojazdy Szynowe PESA Bydgoszcz Spółka Akcyjna ul.Zygmunta Augusta 11 85-082 Bydgoszcz" & @CRLF & _
" NIP 554-031-17-75" & @CRLF & _
" [07-668]" & @CRLF & _
" Lp Opis towaru/uslugi Ilość jm. Cena Wartosc VAT" & @CRLF & _
"-----------------------------------------------------------------------------------------------" & @CRLF & _
" 1 INNE-ELEK-9512 11. szt. 66,00 726,00 23.0% Lampa warsztatowa 30LED z ładowarką" & @CRLF & _
"---------------------------------------------------------------------------------------------- 726,00" & @CRLF & _
"Rozliczenie VAT Netto Podatek Brutto ----------------------------------------------------wg stawki 23.0% : 726,00 166,98 892,98 -----------------------------------------------------" & @CRLF & _
"RAZEM : 726,00 166,98 892,98" & @CRLF & _
"DO ZAPŁATY: 892,98 PLN" & @CRLF & _
"SŁOWNIE : osiemset dziewiecdziesiat dwa zl dziewiecdziesiat osiem gr" & @CRLF & _
"ZAPLACONO GOTOWKA : 0,00 PLN" & @CRLF & _
"POZOSTAŁO DO ZAPŁATY : 892,98 PLN" & @CRLF & _
"PŁATNE : PRZELEW DO 2020.08.07" & @CRLF & _
"NA KONTO : 49 1050 1979 1000 0022 7285 0849" & @CRLF & _
"Za niezapłacone należności w terminie, będą naliczone odsetki w wysokości ustawowej." & @CRLF & _
"Dokument wystawiony i dostarczony nabywcy w formie elektronicznej." & @CRLF & _
"Wystawca dokumentu FV000821 : MIROSŁAW ŚPIEWAK" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")