$re = '/(?i)(?<AllTable>Lp[\s\a]*Opis[\s\a]*towaru\s*\/\s*uslugi[\s\a]*Ilość[\s\a]*jm\.[\s\a]*Cena[\s\a]*Wartosc\s*VAT[\s\a-]*[\s\S]*?)Razem[\s]*:[\s]*(?<WartoscNetto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<KwotaVAT>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<WartoscBrutto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))[\s\a]*Do\s*Zapłaty\s*:\s*(?<DoZaplaty>\k<WartoscBrutto>)\s*[a-z]{3}/mu';
$str = 'AKTURA FV000821 :JAAC*fibf:
DATA WYSTAWIENIA : 2020.06.08 ZLECENIE: 01
MIEJSCE WYSTAWIENIA : TORUŃ
DATA DOSTAWY TOWARU : 2020.06.08 UWAGI : zam. T561552 Z1
SPRZEDAWCA: "MEGA-TOOLS" S.C.
Marek Śpiewak,Mirosław Śpiewak ul.Osikowa 34 87-100 Toruń NIP 9562093313
ING Bank Śląski S.A. O/Toruń
49 1050 1979 1000 0022 7285 0849
NABYWCA: Pojazdy Szynowe PESA Bydgoszcz Spółka Akcyjna ul.Zygmunta Augusta 11 85-082 Bydgoszcz
NIP 554-031-17-75
[07-668]
Lp Opis towaru/uslugi Ilość jm. Cena Wartosc VAT
-----------------------------------------------------------------------------------------------
1 INNE-ELEK-9512 11. szt. 66,00 726,00 23.0% Lampa warsztatowa 30LED z ładowarką
---------------------------------------------------------------------------------------------- 726,00
Rozliczenie VAT Netto Podatek Brutto ----------------------------------------------------wg stawki 23.0% : 726,00 166,98 892,98 -----------------------------------------------------
RAZEM : 726,00 166,98 892,98
DO ZAPŁATY: 892,98 PLN
SŁOWNIE : osiemset dziewiecdziesiat dwa zl dziewiecdziesiat osiem gr
ZAPLACONO GOTOWKA : 0,00 PLN
POZOSTAŁO DO ZAPŁATY : 892,98 PLN
PŁATNE : PRZELEW DO 2020.08.07
NA KONTO : 49 1050 1979 1000 0022 7285 0849
Za niezapłacone należności w terminie, będą naliczone odsetki w wysokości ustawowej.
Dokument wystawiony i dostarczony nabywcy w formie elektronicznej.
Wystawca dokumentu FV000821 : MIROSŁAW ŚPIEWAK
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);