# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?<AllTable>Lp[\s\a]*Opis[\s\a]*towaru\s*\/\s*uslugi[\s\a]*Ilość[\s\a]*jm\.[\s\a]*Cena[\s\a]*Wartosc\s*VAT[\s\a-]*[\s\S]*?)Razem[\s]*:[\s]*(?<WartoscNetto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<KwotaVAT>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<WartoscBrutto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))[\s\a]*Do\s*Zapłaty\s*:\s*(?<DoZaplaty>\k<WartoscBrutto>)\s*[a-z]{3}"
test_str = ("AKTURA FV000821 :JAAC*fibf:\n"
"DATA WYSTAWIENIA : 2020.06.08 ZLECENIE: 01\n"
"MIEJSCE WYSTAWIENIA : TORUŃ\n"
"DATA DOSTAWY TOWARU : 2020.06.08 UWAGI : zam. T561552 Z1\n"
"SPRZEDAWCA: \"MEGA-TOOLS\" S.C.\n"
" Marek Śpiewak,Mirosław Śpiewak ul.Osikowa 34 87-100 Toruń NIP 9562093313\n"
" ING Bank Śląski S.A. O/Toruń\n"
" 49 1050 1979 1000 0022 7285 0849\n"
" NABYWCA: Pojazdy Szynowe PESA Bydgoszcz Spółka Akcyjna ul.Zygmunta Augusta 11 85-082 Bydgoszcz\n"
" NIP 554-031-17-75\n"
" [07-668]\n"
" Lp Opis towaru/uslugi Ilość jm. Cena Wartosc VAT\n"
"-----------------------------------------------------------------------------------------------\n"
" 1 INNE-ELEK-9512 11. szt. 66,00 726,00 23.0% Lampa warsztatowa 30LED z ładowarką\n"
"---------------------------------------------------------------------------------------------- 726,00\n"
"Rozliczenie VAT Netto Podatek Brutto ----------------------------------------------------wg stawki 23.0% : 726,00 166,98 892,98 -----------------------------------------------------\n"
"RAZEM : 726,00 166,98 892,98\n"
"DO ZAPŁATY: 892,98 PLN\n"
"SŁOWNIE : osiemset dziewiecdziesiat dwa zl dziewiecdziesiat osiem gr\n"
"ZAPLACONO GOTOWKA : 0,00 PLN\n"
"POZOSTAŁO DO ZAPŁATY : 892,98 PLN\n"
"PŁATNE : PRZELEW DO 2020.08.07\n"
"NA KONTO : 49 1050 1979 1000 0022 7285 0849\n"
"Za niezapłacone należności w terminie, będą naliczone odsetki w wysokości ustawowej.\n"
"Dokument wystawiony i dostarczony nabywcy w formie elektronicznej.\n"
"Wystawca dokumentu FV000821 : MIROSŁAW ŚPIEWAK\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.