#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((0[1-9]|[12]\d|3[01])-(0[1-9]|1[0-2])-[12]\d{3})$"
Local $sString = "22-10-2000" & @CRLF & _
"10-22-2000" & @CRLF & _
"2-10-2000" & @CRLF & _
"22-1-2000" & @CRLF & _
"2000-10-22" & @CRLF & _
"02-01-2000" & @CRLF & _
"00-10-2000" & @CRLF & _
"22-00-2000" & @CRLF & _
"22-10-0010" & @CRLF & _
"22-10-7000" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")