$re = '/^((0[1-9]|[12]\d|3[01])-(0[1-9]|1[0-2])-[12]\d{3})$/m';
$str = '22-10-2000
10-22-2000
2-10-2000
22-1-2000
2000-10-22
02-01-2000
00-10-2000
22-00-2000
22-10-0010
22-10-7000
// You can show origina post on albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);