package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z][a-z]+,\s[A-Z]{2}`)
var str = `Address
xxx Richardson, TX
yyy Plano, TX
xxyy Wylie, TX WO-65758
zzz Waxahachie, TX WO-999786`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}