import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z][a-z]+,\\s[A-Z]{2}";
final String string = "Address\n"
+ "xxx Richardson, TX\n"
+ "yyy Plano, TX\n"
+ "xxyy Wylie, TX WO-65758\n"
+ "zzz Waxahachie, TX WO-999786";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}