re = /[A-Z][a-z]+,\s[A-Z]{2}/m
str = 'Address
xxx Richardson, TX
yyy Plano, TX
xxyy Wylie, TX WO-65758
zzz Waxahachie, TX WO-999786'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end