using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/|https:\/\/)?[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)*(\.[a-zA-Z0-9]{1,10})((\/+)[^\/ ]*)*";
string input = @"asdf asdf.com asdf.asdf .asdf ..asdf ...asdf asdf...asdf asdf.asdf.asdf/asdf asdf.asdf/asdf http://asdf http://;asdf.asdf.asdf.asdf asdfhttp://asdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}