re = /(http:\/\/|https:\/\/)?[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)*(\.[a-zA-Z0-9]{1,10})((\/+)[^\/ ]*)*/m
str = 'asdf asdf.com asdf.asdf .asdf ..asdf ...asdf asdf...asdf asdf.asdf.asdf/asdf asdf.asdf/asdf http://asdf http://;asdf.asdf.asdf.asdf asdfhttp://asdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end