using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(\w*\w\b)[\w\s]+\s(\w*\w\b)\\n)";
string input = @"Stack Overflow Dot Com\nIS a great website for asking programming questions\nOther Info";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}