$re = '`^(?:(\w*\w\b)[\w\s]+\s(\w*\w\b)\\\\n)`m';
$str = 'Stack Overflow Dot Com\\nIS a great website for asking programming questions\\nOther Info';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);