package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(\w*\w\b)[\w\s]+\s(\w*\w\b)\\n)`)
var str = `Stack Overflow Dot Com\nIS a great website for asking programming questions\nOther Info`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}